Bug: CLK option in Step Sequencer creates double clicks

Bug Reporting
Post Reply
Argitoth
Posts: 189
Joined: 06 Dec 2007 15:05
Location: Mesa, AZ
Contact:

Bug: CLK option in Step Sequencer creates double clicks

Post by Argitoth » 26 Nov 2008 18:35

KarmaFX v1.04
REAPER
Patch: http://www.elanhickler.com/misc/sine-sequence.FXP (hold down a note till the sequence repeats and turn CLK on)

Image
(Step sequencer zoomed ALL the way in)

As you can see, even though i did my best to get rid of that straight line in the step sequencer, it's still there. This causes double clicks when the click option is enabled... i think.

karmafx
Site Admin
Posts: 1180
Joined: 07 Mar 2005 16:37

Re: Bug: CLK option in Step Sequencer creates double clicks

Post by karmafx » 30 Nov 2008 03:35

Oh... Thanks. Looking into that.

Nice explanation btw !! :-)

karmafx
Site Admin
Posts: 1180
Joined: 07 Mar 2005 16:37

Re: Bug: CLK option in Step Sequencer creates double clicks

Post by karmafx » 13 Feb 2009 10:58

Finally tested your patch, Argi. :oops: :D True, there is difference in sound with and without clk.
It is not a bug per se...the problem is that clk really is the "off button" for an internal lowpass filter, so any filtering going on anywhere on the curve is effectively disabled. I don't really see a way around that. :roll:

Post Reply