[FIXED] Strange bugs happening here

Bug Reporting
Post Reply
ksn
Posts: 36
Joined: 26 Apr 2006 15:14
Location: France
Contact:

[FIXED] Strange bugs happening here

Post by ksn » 11 Dec 2008 00:58

Hello Kasper,

I've got a problem in Orion, with a specific patch (i uploaded it here), and a quiet unusual one : when using this patch, if i hit several times the stop button of Orion (this tops the audio engine and put back the play position at the start of the song, kind of "panic" action), then the cutoff is set to 0 on the filter i use in KarmaFX synth :?
I tried with some default patches and it didn't seem to happen...

Edit : when i say "set" to zero, it's definitly, ie : it will stay at zero even if the play button is hit

Also, this patch acted very strangely too in Reaper, but i can't reproduce the problem anymore : it sounded absolutly different (like a very fast arpeggio) and out of tune (several octaves higher)

Finally, another problem in Reaper (but i already met this one with another vsti) which didn't occur previously : if i hit the stop button while a note is played in KarmaFX, then the synth continues to play the notes indefinitly. I have to hit the "rewind" button and go back to start position to stop it.
Maybe it's linked with the bug in Orion ?

I used all the latest versions of the softwares (KarmaFX synth, Orion and Reaper). It seems that these problems don't occur in eXT2.

karmafx
Site Admin
Posts: 1180
Joined: 07 Mar 2005 16:37

Re: Strange bugs happening here

Post by karmafx » 12 Dec 2008 02:43

Thanks for reporting, ksn.

I've downloaded your patch and will take a look at it asap.
Please let me know if you experience the same behaviour in any other hosts.

Thanks again.

karmafx
Site Admin
Posts: 1180
Joined: 07 Mar 2005 16:37

Re: Strange bugs happening here

Post by karmafx » 28 Jan 2009 11:17

I've found and fixed number of midi note on/off related problems (will be in v1.05)...but have yet to verify if this fixes any of the issues your reported.
I'll take a look at the start and stop issues you've experienced...

ksn
Posts: 36
Joined: 26 Apr 2006 15:14
Location: France
Contact:

Re: Strange bugs happening here

Post by ksn » 30 Jan 2009 00:28

Thanks Kasper, looking forward to your conclusions :)

karmafx
Site Admin
Posts: 1180
Joined: 07 Mar 2005 16:37

Re: Strange bugs happening here

Post by karmafx » 10 Feb 2009 14:40

ok, I've repeatedly click play/stop in Orion, and I cannot get this to fail in v.1.05 with the patch you sent.
I'll try to reproduce in v1.04 now, but just to be sure...Let me know if you would like to test a v1.05 prerelease ?

ksn
Posts: 36
Joined: 26 Apr 2006 15:14
Location: France
Contact:

Re: Strange bugs happening here

Post by ksn » 10 Feb 2009 14:49

karmafx wrote:Let me know if you would like to test a v1.05 prerelease ?
Of course

karmafx
Site Admin
Posts: 1180
Joined: 07 Mar 2005 16:37

Re: Strange bugs happening here

Post by karmafx » 10 Feb 2009 21:31

Great! pm sent 8)

karmafx
Site Admin
Posts: 1180
Joined: 07 Mar 2005 16:37

Re: Strange bugs happening here

Post by karmafx » 12 Feb 2009 01:26

ok. first problem in Orion turned out to be related to a knob with a midi controller assigned.

Second problem (Reaper) required a bugfix. Will be in v1.05:
Bugfix: Synth did not respond to "all notes off" midi event causing hanging notes in some hosts. Fixed. (Thanks ksn!)

Thanks again ksn! :mrgreen:

Post Reply