[FIXED] Cubase 3.1.x problems.

Bug Reporting
Post Reply
karmafx
Site Admin
Posts: 1181
Joined: 07 Mar 2005 16:37

[FIXED] Cubase 3.1.x problems.

Post by karmafx » 04 Oct 2010 21:20

It has been brought to attention that KarmaFX Synth v1.11+ doesn't work in Cubase SX 3.1.x (it doesn't show up in the host). It worked fine in v1.10.
I suspect that this is due to the recent upgrade to vst sdk 2.4. :roll:

I'm aware that this version of Cubase is "old" software, but I would like to support as many hosts as possible. Unfortunatly going back to vst sdk 2.3 it's not a viable option.

I will try to investigate if the sdk is in fact the problem, and find a workaround.
Meanwhile I'm very interested if anyone reading this know of other vst's that have this problem, or know any solutions/workarounds? :?:

karmafx
Site Admin
Posts: 1181
Joined: 07 Mar 2005 16:37

Re: Cubase 3.1.x problems.

Post by karmafx » 15 Oct 2010 20:34

Synth has been downgraded again to VST v2.3 (2.4 features were not used anyway),
and some Windows 7 dll dependencies were removed in KarmaFX Synth v1.15.
This seems to have fixed the Cubase SX 3.x.x problem under Windows XP.

I'm awaiting the final verdict from the bug reporter(s).

karmafx
Site Admin
Posts: 1181
Joined: 07 Mar 2005 16:37

Re: Cubase 3.1.x problems.

Post by karmafx » 17 Oct 2010 08:32

Seems there's a still a fatal issue in Cubase! I've had several reports on this. :oops:

While v1.15 is detected as both vst 2.3 synth and effect, it does not appear in the midi out menu, and therefore cannot be used as an instrument on a midi track! (see image below)

I'm not sure what the problem is yet. It's likely due to the vst 2.4 sdk upgrade, but I need to figure out a valid fix. Until then, v1.10 is the latest working version in Cubase SX 3.x.x.

I'm thinking that it might be possible to workaround the issue, i.e., by loading the synth inside a wrapper vsti (e.g. like Chainer, http://www.xlutop.com/html/chainer.html ), but I havn't verified that yet.

Please let me know if you figure out a temporary workaround!

Image

karmafx
Site Admin
Posts: 1181
Joined: 07 Mar 2005 16:37

Re: Cubase 3.1.x problems.

Post by karmafx » 19 Oct 2010 19:57

Found the issue! :shock:
Seems it was due to the vst 2.4 sdk and the deprecated wantevents() call.
Found this thead: http://www.kvraudio.com/forum/viewtopic.php?t=177674
:roll:

I'll be in the shed, making a new build...

karmafx
Site Admin
Posts: 1181
Joined: 07 Mar 2005 16:37

Re: Cubase 3.1.x problems.

Post by karmafx » 20 Oct 2010 17:04

New build (6024) is out for Windows.
Users having midi issues in Cubase SX should download their installer again.

Verified in Cubase SX 3.1.1 by Klaus:
"super, it will work again with "Cubase SX 3.1.1"!
KarmaFX Synth can now again assign a MIDI track.
Thank you for your effort :-)"

Post Reply