Bug!

Bug Reporting
Post Reply
flos
Posts: 80
Joined: 05 Sep 2005 23:13
Location: Rovigo, Veneto, Italy
Contact:

Bug!

Post by flos » 24 Oct 2007 16:08

(L/H)FO+AMP (modulated by envelope) routed into some parameter = crash!

karmafx
Site Admin
Posts: 1180
Joined: 07 Mar 2005 16:37

Post by karmafx » 24 Oct 2007 20:28

:shock: :? if possible please send me a patch just before you hook up what causes the crash, and tell me exactly what you did. Thanks!!

flos
Posts: 80
Joined: 05 Sep 2005 23:13
Location: Rovigo, Veneto, Italy
Contact:

Post by flos » 24 Oct 2007 20:53

OK!

http://www.fileden.com/files/2007/7/11/ ... 0Stuff.kfx

Load the patch (there's not the envelope of the HFO amplifier) and try to play some notes.. if you can... :roll:

karmafx
Site Admin
Posts: 1180
Joined: 07 Mar 2005 16:37

Post by karmafx » 24 Oct 2007 21:28

Thank you !

yep, crashes here too... :oops:
...looking into it !

flos
Posts: 80
Joined: 05 Sep 2005 23:13
Location: Rovigo, Veneto, Italy
Contact:

Post by flos » 25 Oct 2007 17:50

I have found another bug but unfortunately I don't remember how to reproduce it... :oops:
The only thing I can say is that I was doing some patch connection and at one point I saw that one module was connected by a patch chord whose end wasn't connected to anything!!! :shock:
After that the synth became unstable and my host (Minihost) crashed!!! Probably I made some wrong connection between a HFO (or something similar) and something that I don't remember, sorry! :roll:
Anyway it seemed really weird...

karmafx
Site Admin
Posts: 1180
Joined: 07 Mar 2005 16:37

Post by karmafx » 25 Oct 2007 18:49

I've seen that bug too once, flos....thought it was gone.
that crash bug is still keeping me busy though... :roll:

karmafx
Site Admin
Posts: 1180
Joined: 07 Mar 2005 16:37

Post by karmafx » 25 Oct 2007 21:47

seems i've fixed it now. it was due to a bug in the way that polyphonic modulators were handled.

i've also found and fixed a crash bug when "replacing" a modulator module in poly mode.

I will test some more, and try to find the wiring bug you mentioned too, but expect RC8 to be available very soon....

Thanks again!

flos
Posts: 80
Joined: 05 Sep 2005 23:13
Location: Rovigo, Veneto, Italy
Contact:

Post by flos » 25 Oct 2007 22:29

You know that code like your hands! 8)

Post Reply